Blog

Gravatar

GlobeTrotter GT MAX "7.2 Ready" and Vista64 Support

Feb 13

Written by: Ilpo Juvander
2/13/2008 1:13 AM  RssIcon

As I'm almost all the time On-The-Road and thus using wireless access with my laptop I started searching for another data access than my Nokia E90. It has served well for this purpose, but is very limited on battery when connected to 3G network. It lasts only 2-3 hours and after that need to be plugged into the power source. And if you do not do that on time, next time somebody is calling you, the battery is dead...

One limiting factor I also have is Vista64 support, that is a must.

After spending few good moments searching for alternatives, I found a perfect one: GlobeTrotter GT MAX "7.2 Ready". It is promising all the goods, Vista64 support for their software portfolio among all the other goodies:

 image_thumb[2]

So, going to buy one, not an expensive one either.

Saturday 9th of February I finally managed to get to an shop to get one. Hurry back home to get it installed, smoothly card in to the laptop and that's it?

untitled_thumb[2]

Hmm, everything started smoothly, it found the card, installed some USB removable disk drives (Zero-CDTM patented technology from Option), but then started trouble: Vista64 started to ask drivers for it, complaining about not finding an suitable one.

Ok, normal stuff, card had old drives attached to it, lets get newer ones. The ones which came with card were version 2.0, there must be newer ones. Option's support site asked for serial number and IMEI number of the card:

image_thumb[7]

After putting in the numbers from card, reply was that numbers were not recognized. Hmm - let's open an support case to get these in place. This was on Saturday evening, on Monday afternoon an reply came that the problem is solved and I would have access to the site.

New try. Now I could get in and surprise surprise, on the site there were still the version 2.0 non-working version of the drivers! Back to support and after a while they updated version 2.2.0.536 drivers.

So, back to installing these. And the end result was...

clip_image001_thumb[2]

Description:

  Windows detected a new device attached to your computer, but could not find the driver software it needs to make the device usable. Each device manufacturer typically includes driver software of a CD that comes with the device, or as a download from its web site. The hardware ID of your device is USB\VID_0AF0&PID_6701&REV_0000.

Problem signature:

  Problem Event Name:                        PnPDriverNotFound

  Architecture:                                       x64

  Hardware Id:                                        USB\VID_0AF0&PID_6701&REV_0000

  OS Version:                                          6.0.6000.2.0.0.256.6

  Locale ID:                                             1033

Hmm- what is happening, I just got updated driver set and this was the end result! Back to support.

Then started happening amazing things. They put forward an *older* version of the drivers, version 2.1! Normally you get newer ones, but in this case older ones... well, lets give it a try.

Uninstall and install again, same procedure and the result exactly the same as with version 2.2 drivers, Vista is still after the drivers as it could not find these from the setup. Hmm.

Back to support.

Now it was already Tuesday and newer answer arrived: Again drivers to download, this time they were version 2.3.0.630! Hey, don't these guys know what's in their driver kits???

But, another trial. Uninstall and install these again and big things happened: Vista did not complain about missing drivers! Could this be true... No, after starting the Globetrotter Connect it showed that Device not found:

clip_image001clip_image001[4]

After this I have not got any real suggestions on what could be wrong with this one.

I already started the return process of getting this card back to where it came from, but the answer from Mikko Dunderfelt / Verkkokauppa.com that because Finnish distributor Mobile World Communications Oy Ltd says that Vista is supported, no returning for it!

I ended up being a bit curious to see also if it was about my laptop that was causing this so I took a look at the drivers included in these different version that were offered. Here's the results:

  • Version 2.0: Vista64 drivers not included at all
  • Version 2.1: Vista64 drivers not included at all
  • Version 2.2: Vista64 drivers included, but not for GlobeTrotter GT MAX "7.2 Ready". And how can I tell this? Just by searching the cards identifier PID_6701 from the *.inf files installed. It was not included in there.

So the end result of this is that I have a working data card, tested in Windows XP, but without promised Vista64 drivers which was the one I was after!

For the data card manufacturer Option from Belgium I recommend that they try to keep up with their hardware and software offering so that they know which is compatible and with what. Right now they are promising something else than what is really out there!

Bad choice for data card, keep away from these guys in the future.

I can't wait for tomorrow to see how this will end.

Tags:
Categories: Misc
Location: Blogs Parent Separator Ilpo Juvander